Back to overview
Degraded
Privacy Request Error
May 12 at 05:13pm BST
Resolved
May 18 at 05:06pm BST
We have identified the issue and are monitoring it.
Affected services
Updated
May 16 at 06:35pm BST
We're still looking into this.
Affected services
Created
May 12 at 05:13pm BST
Some people are getting a REACH PRIVACY REQUEST prompt when clicking on newsletter links.
Affected services