Back to overview
Degraded

Newsletters have been cut down

Jul 14, 2023 at 10:40pm UTC

Resolved
Jul 24, 2023 at 4:34am UTC

Newsletters are back to normal.

Created
Jul 14, 2023 at 10:40pm UTC

The website is being translated into more languages, which keeps me quite busy and causes a shortage of content in newsletters.