Back to overview
Downtime
Link Shortener, Website Forms, and 1 other service are down
Aug 28, 2024 at 6:12am UTC
Affected services
Clickable Links
Website Forms
Resolved
Sep 7, 2024 at 5:46pm UTC
fixed
Affected services
Updated
Sep 5, 2024 at 6:33am UTC
Redirects up.
Affected services
Updated
Sep 5, 2024 at 6:30am UTC
Redirects recovered.
Affected services
Updated
Sep 3, 2024 at 8:55am UTC
Link Shortener recovered.
Affected services
Updated
Aug 30, 2024 at 2:18pm UTC
Link Shortener recovered.
Affected services
Created
Aug 28, 2024 at 6:12am UTC
Website Forms recovered.
Affected services