Back to overview
Degraded

Degraded site performance

Aug 25, 2025 at 4:00pm UTC
Affected services
Main Website
Clickable Links

Resolved
Aug 27, 2025 at 1:07pm UTC

This incident has been resolved.

Updated
Aug 27, 2025 at 12:50pm UTC

A fix has been implemented and I am monitoring the results.

Updated
Aug 27, 2025 at 10:02am UTC

The issue has been identified and a fix is being implemented.

Updated
Aug 27, 2025 at 5:54am UTC

I am currently investigating elevated errors with redirects and am actively working on a fix.

Created
Aug 25, 2025 at 4:00pm UTC

The site is experiencing degraded performance and some outlinks or links to third-party services do not work.